Search for:
  • Home/
  • India/
  • T.N. Rains | Extremely heavy rains ravage southern districts triggered by a cyclonic circulation over Comorin area

T.N. Rains | Extremely heavy rains ravage southern districts triggered by a cyclonic circulation over Comorin area

[ad_1]

A video grab of flooded paddy fields in Tirunelveli district, on Sunday, December 17, 2023

A video grab of flooded paddy fields in Tirunelveli district, on Sunday, December 17, 2023
| Photo Credit: PTI

Torrential rains pummelled the southern districts of Tamil Nadu with an unprecedented amount of rainfall on Sunday, December 17, 2023, as the Northeast monsoon is in its vigorous phase.

In the past 24 hours ending 8.30 a.m. on Monday, Kayalpattinam in Thoothukudi district received a whopping  95 cm of rainfall.

Extremely heavy rains had pounded several southern districts, triggered by a cyclonic circulation over the Comorin area and its neighbourhood. Tiruchendur and Srivaikuntam in Thoothukudi district received 69 cm and 62 cm respectively. Moolaikaraipatti in Tirunelveli district recorded 61 cm.

Some of the other places that recorded historical rains include: Manjolai in Tirunelveli district (55 cm), Kovilpatti in Thoothukudi district (53 cm), Gundar Dam, Tenkasi district (51 cm), Oothu, Tirunelveli district (50 cm) Nalumukku, Tirunelveli district, (47 cm), Palayamkottai, Tirunelveli district (44 cm), Ambasamudram, Tirunelveli disitct (43 cm), Maniyachi, Thoothukudi district (42 cm,) Cheranmahadevi, Tirunelveli district (41 cm) and Kannadaian Anicut in Tirunelveli district (41 cm).

The Regional Meteorological Centre has noted that heavy to very heavy rains may continue in four districts: Kanniyakumari, Tirunelveli, Thoothukudi and Tenkasi on Monday, December 18 as well. Rains may reduce from Tuesday.

In a post on social media, weather blogger, the Tamil Nadu Weatherman has said this is the second-highest rainfall of since Kakkachi (Manjolai) received 96.5 cm in 1992.

[ad_2]

Leave A Comment

All fields marked with an asterisk (*) are required